Sunday, April 17, 2011

Perintah Dasar CLI CISCO

Berikut ini daftar perintah dasar yang sering digunakan dalam mode CLI (Command Line)


1.  Setting Password
router>enable
router#configure terminal
router(config)#enable password forumsains (set password untuk masuk ke mode privilege)
router(config)#enable secret secret (set enkripsi untuk password yang  disimpan)


2. Setting Host Name
router>enable
router#configure terminal
router(config)#hostname nama-host


3. Setting VLAN
router>enable
router#configure terminal
router(config)#vlan nomor-vlan
router(config-vlan)#name nama-vlan



4. Setting IP Address pada VLAN
router>enable
router#configure terminal
router(config)#interface vlan 1
router(config-if)#ip address address mask (misal: ip address 172.10.46.1 255.255.255.0)
router(config-if)#no shutdown


5. Setting Identitas pada Port Cisco Catalyst
router>enable
router#configure terminal
router(config)#interface nama-port
router(config-if)#description “Port Setting Identitas”
router(config-if)#end



6. Setting IP Gateway
router>enable
router#configure terminal
router(config)#ip default-gateway address


7. Setting Port-Speed dan Link-Mode
router#configure terminal
router(config)#interface nama-port (misal : interface fast ethernet 0/1)
router(config-if)#speed 100
router(config-if)#duplex full
router#configure terminal
router(config)#interface nama-port
router(config-if)#switchport mode access
router(config-if)#switchport access vlan nama-vlan
router#configure terminal
router(config)#interface nama-port
router(config-if)#switchport mode trunk
router(config-if)#switchport trunk allowed vlan nama-vlan


8. Setting Line VTY
router#configure terminal
router(config)#line vty 0 4
router(config-line)#login
router(config-line)#password password


9. Setting Line Con 0
router#configure terminal
router(config)#line con 0
router(config-line)#login
router(config-line)#password password


10. Melihat Semua Konfigurasi
router#show running-config


11. Menghapus Semua Konfigurasi
router#erase startup-config
router#dir
router#delete flash:vlan.dat
router#dir
router#reload

12.Setting Password Console dengan Username
router(config)# username USER password WORD
router(config)# line console 0
routerconfig)# login local (local hanya jika ada username)

13.Setting Password Telnet dengan Username
router(config)# username USER password PASS
router(config)# line vty 0 4
routerconfig)# login local

14.Setting Encryption Password
router(config)# service password encryptiton

15.Setting Banner
router(config)# banner metd # [enter]
pada akhir pesan diakhiri tanda #
atau

router(config)# banner exec # [enter]
pada akhir pesan diakhiri tanda #

Sementara itu dulu ya, ntar kalau langsung kokean dadine muntah-muntah, sedikit-dikit tapi rutin, semoga bermanfaat. Sukses Selalu.

3 comments: